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A Day In The Life
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STARTING YOUR DAY 
Updating Your Software 
It is important to update your software as soon as an 
update becomes available for download.  The 
Update Manager is used to obtain and install files 
that update the federal and state packages of the 
Drake Software program. You can download your 
updates manually or set up your software to receive 
them automatically. 
MANUAL UPDATES 

1) From the Home window of Drake Software, go to Tools > Update Manager to open the 
Drake Update Manager dialog box. 

2) Click Get Updates.  
3) The software checks for updates and, if any are found, prompts you to install them. 
4) Click Yes to continue the process, or No to close the message box and return to the Drake 

Update Manager. 
5) If you clicked Yes, the software alerts you that all users must exit the software and that the 

software must be closed, then asks for confirmation. 
6) Click Yes to continue the process, or No to close the message box and return to the Drake 

Update Manager. 
7) When your response is Yes, the program will be closed and the update installation process 

will be completed. 

AUTOMATIC UPDATES 
You can set up your program to automatically install updates. 

1) From the Home window of Drake Software, go to Tools > Update Manager to open the 
Drake Update Manager dialog box. 

2) From the Drake Update Manager, select Auto Update Settings. This opens the Auto 
Update Manager. 

3) In the Options section, make sure the automatic updates are On. 
4) Select a time for Next Check. This is the time the system will check for, download, and 

install updates. 
5) To exit the screen, click Hide when the feature is turned on, Exit when the feature is turned 

off, or press ESC to close the dialog box without saving any changes. 
 

 
VIEW RELEASE NOTES 
When updates are installed, an Installation Log is created that provides the file name of the update, 
the release date, update number, and access to release notes (double-click the line). Release Notes 
are found in the lower pane of the Drake Update Manager window or they may be accessed 
through Reports > Report Viewer, Release Notes tab. 

NOTE: If you choose to install your updates automatically, select a time that typically no one will be 
working in the software, since all users must exit the software and the software must be closed 
during the installation process. The downloading computer must be left on and have an Internet 
connection. An update reminder will be displayed until you update your software. 
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PREPARING RETURNS 

Data Entry 
OPENING A RETURN 
Open a return from the Home window in any 
of the following ways: 

o Select a return from the last nine 
accessed returns appearing in the 
Recent Returns list.   

o Press CTRL+O. 
o Click Open/New and enter the SSN or 

EIN of the return.  
o Go to File > Open/Create Returns. 

 
 
CREATING A RETURN 

1) Press CTRL+O.  

 
2) In the Open/Create a 

New Return dialog 
box, enter the client 
ID number.  
 

3) Press Enter.  
 

4) Press Enter when 
asked if you want to 
create a new return. 
 

5) Press Enter in the 
New dialog box or 
select a different 
return type; enter the 
client name. 
 

6) Press Enter. Data 
entry screen for the 
new return is 
displayed. 
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DATA ENTRY MENU 

Returns are prepared in data entry mode. Navigate through the tabs to find specific screens.  
Access data entry screens from the Data Entry Menu by either:   

o Typing a screen name or Search Phrase in the selector field 
o Clicking the screen description 
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Keyboard Shortcuts / Unpublished Codes 

Advance the cursor one field    ___________ OR ___________ 

Move the cursor BACK one field    ___________ OR ___________ 

Exit and save a screen     ___________ 

Exit a screen WITHOUT saving your changes  ___________ 

Reset a screen to the last save BEFORE exiting ___________ 

Get field-specific, context-sensitive HELP!   ___________ 

Scroll through multiples of the same screen  ___________ AND ___________ 

Toggle into and out of “Field-Number” data entry ___________ 

Calculate and display summary results   ___________ 

Calculate and View the actual tax return   ___________ 

Jump from View/Print back into Data Entry  ___________ 

Get to a detail Worksheet for any numerical field ___________ 

Split a joint return and compare with MFS  ___________ 

Delete any screen, while on that screen   ___________ 

Search for business codes on Sch C   ________________ 

Unpublished Codes  2nd PIN Screen ________ (State-Specific) 

Label Print ________ Launch Email ________ Sort Depr ________ 

Get Help ________ Open Tax Planner ________ Doc Mgr ________ 

Calc Summ ________ Calculate & View ________ Calc / Print ________ 
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REVIEWING AND SHARING RETURN RESULTS 
Calculating a Return, Then Display a Summary Result Page 
To calculate a return from data entry, press CTRL+C or click Calculate from the toolbar.   
SUMMARY CALCULATION RESULTS 
Results are displayed in the Calculation Results window. The top section of the Summary tab contains 
rows referring to the federal return and all state returns prepared for this individual or business. The columns 
list income, taxable income, total tax, refund or balance due, payment method, and an eligibility indicator for 
e-filing. 
The EF Messages section lists any problem that would prevent e-filing. Double-click the message for a full 
description of the EF message (or see the Message pages in View mode). If the EF message is displayed 
as a blue link, double-click to go directly to the data entry screen in question, and in some cases the exact 
field. Return Notes, located at the bottom of the window, are for informational and diagnostic purposes and 
do not prevent electronic filing.  



 

7 
VIEW AND PRINT 

To view the return, press CTRL+V. The return is first calculated by default. You can select in 
Setup > Options if you would like for the Calculation Results window to open before you are 
directed to View/Print mode. 

VIEW/PRINT MODE – SCREEN OVERVIEW 

This is a combined View/Print screen. It consists of the following: 

o A toolbar with various speed buttons. 

o Navigation bar for paging through the forms and zoom tool. 

o Category tabs that allow you to view portions of the return. 

o A tree view of all the forms, worksheets, and other documents produced for the return. The 

tree can expand and collapse. 

o The viewing panel, where the selected forms in the tree view are displayed.    
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Printing Documents 

PRINTING A SPECIFIC FORM  
To print a specific form, press press 
<ENTER> while a form is displayed. 
Other options for printing specific forms: 

o Print Selected Forms – To select 
forms, use the Spacebar.  To print 
all the forms selected (those forms 
with a checkmark), press 
<ENTER>, or from the toolbar, 
click the arrow next to Print and 
choose Print Selected Form(s). 

o Quick Print – Even if you have several forms selected to print, you can choose to print just 
the form displayed in the viewing panel (which is highlighted in blue in the tree view). Press 
CTRL+Q or from the toolbar, click the arrow next to Print and choose Quick Print. 

 

DRAKE PDF PRINTER 
Print the forms on paper or Print Selected Form(s) to PDF by pressing CTRL+D, or from the 
toolbar, click the arrow next to Print and choose Print Selected Form(s) to PDF Document. The 
Drake PDF printer is specifically designed to encrypt PDFs created in the software. The Drake 
PDF Printer cannot be used outside of Drake Software. 
 
E-mailing Returns 
The Drake E-mail program allows you to send and receive e-mails directly from within Drake Software. 
SENDING AN EMAIL FROM DATA ENTRY 
From within a return, on the Data Entry, select the Email button. An e-mail window is opened with 
the client’s data file automatically attached.  Because the client data file can be opened only with 
Drake Software, this feature is typically used when e-mailing a Drake Software Customer Support 
Representative, not your clients. 
SENDING AN E-MAIL FROM VIEW/PRINT 
To e-mail your clients some or all of their tax return documents, use the Email feature in 
View/Print mode. 
To send a return to a client from View/Print mode: 

 
1) Open the return. 
2) Click View or Print to access View/Print mode. 

 

3) Select the forms to be included in the e-mail.  All the forms selected will be included 
in one PDF document. 
 

4) Click Email from the toolbar to use the default e-mail method, or click the arrow next 
to the Email button to choose a sending method. The Password Protect dialog box 
is opened, showing the password.  You can change it from the default if desired. 
 

5) Click OK. The e-mail message is opened in the desired e-mail program, with the 
selected return documents attached.  The client and spouse e-mail addresses are 
automatically shown in the To field if they were entered on screen 1.  The default 
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language in the body of the e-mail, as designated in your Email Settings, is also 
displayed.  You can edit any of the default information that is automatically included 
in the e-mail message on a per return basis. 
 

6) If no further changes to the message are needed, click Send.   
 

 
 
 
 
 

SENDING AN E-MAIL FROM HELP > EMAIL  
You can access the e-mail program from 
the Drake Home window. Go to Help > E-
mail.  The Drake Email program has useful 
features designed specifically with the tax 
preparer in mind.  
MESSAGE ATTACHMENT 
Click New to create a new mail message.  
Click Attach to attach documents to the 
message. 
 
ADDRESS BOOKS 
When you address an e-mail in the Drake Email program, you have several address books from 
which to choose.  
To access the address books, click the To button to view the list of address books: 

o Drake Software Support Address Book – Contains general Drake e-mail addresses, such 
as Customer Support, Accounting, Federal/State, and Spanish. 

o entered on screen 1 in data entry. 
o Local Address Book – Contains your personal addresses that you can add to or edit 

yourself. 
o Report Generated Recipient List – Allows you to send customized mass e-mail 

messages to your clients using the Drake Software Report Manager. 

 
ORGANIZING DOCUMENTS 
Drake Document Manager (DDM) 
The DDM is part of the Drake Software suite and offered as part of your Drake package. It allows 
you to develop a paperless office by storing files electronically.  
DDM FILE STRUCTURE 
When you update a return from the prior year’s software into the current year’s software, you 
automatically create a folder in the DDM for that client. This also brings forward prior-year DDM files 
year by year, so that each year will be listed under the client in the current year DDM. 
OPENING THE DDM 
Use any of these methods to open the DDM: 

o Click the DDM icon on your desktop. 
o From within data entry of a return, click Doc Mgr to go directly to the client’s folders within 

the DDM. 

NOTE: Even though you must open a specific return to indicate your e-mail settings, 
those settings will apply to all of your returns, not just the return you are in.  From 
View/Print, go to Email > Email Setup. 
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o From the Archive button in View/Print mode, go to Archive > Document Manager to open 

the DDM.   
 

SAVING THE TAX RETURN TO THE DDM FROM VIEW/PRINT  
1) Go to View/Print mode and select 

the forms to save in PDF 
format. 

2) From the toolbar, click the 
Print drop arrow. Select 
Print Selected Form(s) to 
PDF document. 

3) Next, the print dialog box 
is opened. Notice that the 
printer selected is the 
Drake PDF Printer. 

4) Click Print.  

5) You are prompted to save 
the PDF file. The file is 
automatically saved in a folder 
for the client in the DDM. 
Name the file appropriately 
and click Save.  

PRINTING A FILE TO THE PRINTER 

AND SENDING A COPY TO SECURE 

FILE PRO 

If you are printing a digital copy for your 
client and would like to send it to them 
via your portal, you can do so from the 
Print dialog box. Print the return and 
mark the box to Send to Portal. 
 
 
Archiving Returns 
When a return is archived:  

o A current version of the client file is archived. The copy or version that is saved can be 
restored in the future if necessary.  Create as many archives or “versions” of the return as 
you would like. 

o A PDF of the return is created and saved in the client’s DDM folder. 

CREATING A RETURN ARCHIVE 
To create a return archive: 

1) Press CTRL+P or CTRL+V to open View/Print mode for the return. 

2) From the toolbar, go to Archive > Archive Client Return. 
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3) Enter a description for the archived file.  For example, “completed return.” 
4) Click OK. You are prompted when the archive is created. 

 

RESTORING ARCHIVES 
To restore an archived version of a return: 

1) From the Data Entry menu, press CTRL+P or CTRL+V to enter View/Print mode for 
the return. 

2) From the toolbar, go to Archive > Archive Manager. The Archive Manager is opened. 
3) Click to select the archive to restore. 
4) Click Restore to restore the selected version. 

E-FILING RETURNS 
Electronic Filing 
To e-file a return in Drake Software, take the following steps: 

1) Calculate the return.  Verify the return is eligible for e-file from the Calculation Results 
window.  You will have a green check mark on the Federal line and on the line for any eligible 
states.  

 
 
 
 
 
 

2) Prepare the transmission file.  From the 
Home window, go to EF > Select 
Returns for EF and select the files to 
be e-filed in this batch in the Return 
Selector.   
 

3) Transmit the return.  The 
Transmit/Receive window is your last 
chance to prevent a file from being 
transmitted.  Click the Review button to 
view which files will be transmitted.  If 
necessary, remove files that should not 
be transmitted at this time. 
 
 

 
  

NOTE: If the Require ‘Ready for EF indicator’ on the EF screen field is marked on 
the EF tab under Setup > Options, you must first indicate you are ready to transmit 
the return by making sure the Ready for EF field has an “X” in it on the EF screen in 
data entry. 
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Once you have reviewed the files being transmitted, click Send/Receive.   

 

 
 
 

 
 
 
 

4) Process Acknowledgements.  Once your acknowledgements have been “picked up,” go 
to EF > Process Acks to process the acknowledgements.  You will be able to view 
information about the acknowledgements in a report.  
 

DRAKE ACKNOWLEDGEMENT CODES 
o P – Tax return transmitted successfully to Drake. Return is being processed. 
o T – TEST return transmitted successfully to Drake. 
o B – Bad transmission.  Be sure to read the error code so you will know why the B ack was 

returned.  Correct the return and retransmit. 
 

IRS ACKNOWLEDGEMENT CODES 
o A – Tax return has been accepted by the IRS. 
o R – The return has been rejected by the IRS. 

NOTE: When clicking Send/Receive, not only are you transmitting the returns 
selected, you also are downloading any federal and state acknowledgements that 
have been posted by Drake.  To pick up acknowledgements without transmitting any 
returns, click Acks Only. 
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o D – Tax return is a duplicate of a previously filed return or DCN; rejected by the IRS. 
o E – Imperfect return. 

 

Viewing e-Filing Information 
View e-filing information about your client’s return in your EF Database.  From the Home 
Window, go to EF > Search EF Database.   

 
 

The following tabs of information are available:  
o F1 – General Information tab displays basic taxpayer information along with IRS 

Acknowledgements, State Acknowledgements, and Reject Codes. 
o F2 – Bank/Direct Deposit Info tab contains detailed information about any bank products. 

o F3 – Fees/Miscellaneous Info tab contains general return information about the taxpayer, 
firm, and fees distribution. 

o F4 – Reject Code Lookup tab is a search tool for accessing and understanding IRS reject 
codes. 

Buttons are available to help you navigate:  
o F5 – Data Entry allows you to return to data entry for the return. 

o F10 – Online DB takes you to your online EF database, which is also accessible through 
the Drake Support website. 
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To look up an IRS reject code for a federal return: 

 
1) Select a federal return type (1040, 1120, 1065, 1120S, or 1041). 

 
2) Enter the reject code in the Reject Code field. 

 
3) Click Go. The IRS explanation of the code is displayed in the lower box. 

 

BACKING  UP DATA 
Backing Up 
Client Files 
We recommend that 
you back up your files 
frequently during tax 
season.  Backing up 
your files ensures the 
files are available in the 
event of a disaster, 
such a hard drive crash. 
 
There are all-new 
options for backup, 
including automatic 
backup and backup to 
your SecureFile Pro 
account! 
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Macros 
What is a Macro?  
Macros make the process of repetitive data entry easier by allowing YOU to assign a string of data 
to a keyboard shortcut.   
 
It’s just like a  _______________ and _______________ device, except it 
_______________ _______________. 
 
Macro Recorder at Drake Home Screen > Setup > Macros 
Macro Playback: Works Only in Data Entry 
   Keystroke sequence to Playback:  ________ ________ 
 

Setup>Macros allows you to create macros for use in data entry.  For your reference, you can 
print a list of your macros from Setup Macros, using the Print button. 
On the Drake Software Home Screen, select the “Setup” menu, then the option “Macros”: 
  Then this screen will be displayed: 
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Setting up Macros 

1. After selecting Setup > Macros, and the Setup Macros dialog box is open, you’ll find 
available keystrokes displayed in the Hot Keys column.  The Data column contains the 
data string associated with the keyboard shortcut. 

2. Double-Click in the Data column, next to the keyboard shortcut you want to use.  The Edit 
Macro screen is displayed.  (See the next page for a screen shot.) 

3. Type the text and/or controls to  
4. When done, click Save, or press Alt-S. 

 

Operation Symbols – These codes will, during macro execution, perform these functions: 
*  Will bypass the multi-selection window while a macro is running (Asterisk) 
+  Will tell a macro NOT to clear flagged fields as the macro is running (Plus) 
<  Moves the focus back one field (Less-Than Symbol) 
>  Moves the focus forward one field (Greater-Than Symbol) 
~  Escapes the screen and saves the data (Tilde ~ AKA that squiggly line thingy) 
#  Represents initiation of “Toggle Heads Down Mode” (Pound Sign or Hashtag) 
[D]  Inserts the Current Date (Note the square brackets – NOT parentheses) 
[HOME]  Initiates the Home Key 
[END]  Initiates the End Key 
[FF:##] Field Forward (## is the number of times to move ahead) 
[FB:##] Field Backward (## is the number of times to move backward) 
[FJ:##]  Field Jump (## is the field number in which you want the cursor positioned) 
?  Pauses to wait for input (Gets input from you then resumes macro execution) 
[NEW] Creates a new screen selection; for example *C[NEW]> opens a new 

Schedule C.  *C[1]> will open the first Schedule C where multiples exist. 
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